Honda TRX250R Forums banner
1 - 9 of 9 Posts

·
Registered
Joined
·
232 Posts
Discussion Starter · #1 ·
I just recently finished a total rebuild of my 86 310r and im already running into problems. When i first got the quad last fall i was having problems with it feeling like it was hitting a rev limiter about mid rpm and it wouldnt rev out fully. I figured i would worry about it after i got done rebuilding it if it was still doing it. After i got the motor broke in and i went for its first ride it was still doing the same thing. So i pulled the cdi box off ( a red one ) and stuck it on my buddies 250r and it made it do the same thing mine was doing, bad cdi box right? So i ordered a new one and when it got here i put it on my bike and it ran worse than before, cutting out bad after about 1/4 throttle. So i put the new one on my buddies bike and it done the same thing again. My buddies bike was kind of cutting out in high rpms before we started swapping cdi boxes around so i figured i would try his cdi box on my quad and ill be damned if it didnt make my bike do the same thing. 3 cdi boxes, ( one red and 2 black ) one of them bran new and all of them are bad. What is the deal with junk cdi boxes? Does anybody have a good cdi box they would part with or know where i can buy a good one? This is really frustrating.
 

·
Registered
Joined
·
989 Posts
check your wires and connectors REAL GOOD

ANY yes ANY yellow or brown spots on the white connectors means a bad connection causing heat... more times then not its the connections that gets the wrong diagnosis and a component gets junked only to find the problem still persists...

connectors, connectors!!!!! check them with a bright light if shining light on them shows any spots that's were I would start
 

·
Registered
Joined
·
7 Posts
I have a red cdi on my quad and as soon as I plugged it in my quad runs like crap! I am going to get the cr250 cdi set up. No more messing around!
 

·
Registered
Joined
·
1,017 Posts
I had a ricks cdi on my 330 it would kick back real badstart hard and feel real sluggish. Almost like the motor was seizing up. Got a brand new oem cdi and it fires in 2 kicks cold.
 

·
Registered
Joined
·
232 Posts
Discussion Starter · #5 ·
Well no luck, i called the local honda dealer today and they told me honda has discontinued the oem cdi box and all i can get now is aftermarket, wtf? Anybody know where i can get a good oem cdi box?
 

·
Premium Member
Joined
·
13,280 Posts
check your wires and connectors REAL GOOD

ANY yes ANY yellow or brown spots on the white connectors means a bad connection causing heat... more times then not its the connections that gets the wrong diagnosis and a component gets junked only to find the problem still persists...

connectors, connectors!!!!! check them with a bright light if shining light on them shows any spots that's were I would start
I have a red cdi on my quad and as soon as I plugged it in my quad runs like crap! I am going to get the cr250 cdi set up. No more messing around!
Well no luck, i called the local honda dealer today and they told me honda has discontinued the oem cdi box and all i can get now is aftermarket, wtf? Anybody know where i can get a good oem cdi box?
X2....OEM only, even used OEM is better. Look on eBay forna good known working OEM CDI, or call us.

Carlos
 

·
Registered
Joined
·
113 Posts
If you put the money into getting a 310 i'd get a cr 250 ignition, if no headlight is an issue wait a little longer for carlos to release his ignition
 

·
Registered
Joined
·
1 Posts
X2....OEM only, even used OEM is better. Look on eBay forna good known working OEM CDI, or call us.

Carlos
Hi I have 3 250R's and am trying to get them up and running only one has spark and long story short the other 2 dont and the only thing thats different is 2 of them have the same setup as per CDI/COIL and the 1 that doesnt is the only one that sparks. So I assume its either Stator, CDI, COIL. OR some combo of the 3. Read you know all about CDI/Coil and such. Any Suggestions.
 

·
Registered
Joined
·
4,285 Posts
Hi I have 3 250R's and am trying to get them up and running only one has spark and long story short the other 2 dont and the only thing thats different is 2 of them have the same setup as per CDI/COIL and the 1 that doesnt is the only one that sparks. So I assume its either Stator, CDI, COIL. OR some combo of the 3. Read you know all about CDI/Coil and such. Any Suggestions.
imo swop out the known good cdi first.used ones are out there but plan on paying $200 each.
 
1 - 9 of 9 Posts
Top