Honda TRX250R Forums banner

1 - 8 of 8 Posts

·
Registered
Joined
·
19 Posts
Discussion Starter #1
Hello, just put my project 250r back together and im noticing a ton of kickback when trying to start it and am noticing a delay in the spark arrival time to the spark plug. I have a ricks hot shot cdi and i just replaced the stator, using a new spark plug and new ignition coil. I have tried using a fully functional oem cdi but have had no luck with fixing the kickback or with having it start (only wants to fire with the ricks cdi).

Could somebody point me in a good direction to diagnose my problem, im not sure where to begin. Thank you!
 

·
Registered
Joined
·
369 Posts
Have you checked your flywheel? Is the woodruff key still intact? Are the flywheel magnets coming apart? The oem cdi works on another R? Have you tried the hotshot cdi on another R?

Loren
 

·
Registered
Joined
·
19 Posts
Discussion Starter #3
Have you checked your flywheel? Is the woodruff key still intact? Are the flywheel magnets coming apart? The oem cdi works on another R? Have you tried the hotshot cdi on another R?

Loren
Ive been swapping out flywheels every now and then, i have 2 oem flywheels that are in tact and am not noticing a difference when i change them. I just replaced my woodruff key today because i saw it was worn down but haven’t noticed any difference. Im not sure it the magnets are comming apart, i don’t believe they are. I have tried both on another 250r and they both test good.

I had my 250 running great before i tore the motor apart, i was running an old oem stator and oem flywheel with the hotshot cdi and an old answer roost boost and it started 1st-2nd kick with some kickback. But I eliminated the roost boost just so i can eliminate as many potential problems as possible and i cant seem to figure it out
 

·
Registered
Joined
·
19 Posts
Discussion Starter #5
shake the flywheel if it rattles it's bad.screw ricks cdi..and you might have a bad oem cdi.find a good used one.
The guy i got my oem cdi off of used it for testing his other 250rs and he siad it worked just fine, but ill try shaking the flywheel to see if theres any rattling
 

·
Registered
Joined
·
13,187 Posts
The guy i got my oem cdi off of used it for testing his other 250rs and he siad it worked just fine, but ill try shaking the flywheel to see if theres any rattling
Post picture of OEM CDI; let's verify it is a genuine OEM CDI first.

Carlos
 

·
Registered
Joined
·
13,187 Posts
It has the blue and white lettering on the side of the plug in but i can post a picture when i get home
If it's a real OEM CDI, and it kicks back, then check all electricals to Honda specs with an OHM meter, shake the flywheel, inspect pickup, ON/OFF switch, Harness connections, Ground, Saprk Plug Boot, Wire, check reeds for cracks or brakes, make sure carb is jetted correctly…. if all checks out good, then most likely the OEM CDI is bad.

Carlos
 
1 - 8 of 8 Posts
Top